Engages being shown to unexpected users
Incident Report for Admiral
Postmortem

If your site was affected by this incident you will have received an email from bryan@getadmiral.com notifying you.

At 9:20am on March 30th we automatically migrated all customers to our new web application that had not yet done so manually. This migration unfortunately did not account for an older implementation of multi-engage Journeys that still exists on a small subset of live customer sites (59 sites total). This caused the second Engage in these Journeys to display to all visitors on every page view. In virtually every case this engagement was asking users to disable their adblocker.

Soon after the migration we recognized the misconfiguration and began the process of restoring a backup of the database that stores Journey configurations. The backup completed at 11am and all misconfigured Journeys were restored to their original state. This rollback reverted the database to its state at 8am on the same day. Any changes made between 8am and 11am on March 30th should be resubmitted if you wish for them to persist.

If you have any questions about this incident please email support@getadmiral.com.

Posted Mar 31, 2022 - 11:45 EDT

Resolved
We will be restoring all affected Engages back to their original targeting
Posted Mar 30, 2022 - 10:00 EDT