Subscription site showing error
Incident Report for Admiral
Postmortem

Overview

Between 9:56 ET and 10:34 ET on October 18, 2023, Engage adblock instructions, VRMBot, and the subscription management site experienced complete outages worldwide.

Incident Summary

During the timeframe visitors trying to subscribe or login were shown an error message. Visitors trying to load adblock disable instructions were also shown an error. Finally, for sites that have VRMBot enabled, it did not load correctly. All of these issues were simultaneously corrected.

Root Cause Analysis

A configuration change was deployed as part of routine maintenance led to the unavailability of part of our web serving platform. Admiral separates the serving web properties which limited the blast radius to only a few services.

Mitigation Steps

Once the change was identified as the cause it was corrected and re-deployed to the relevant infrastructure. The corrected deployment started at 10:24 ET and finished at 10:34 ET.

Preventive Measures

Admiral will continue to improve our deployment tooling and early-warning systems to catch these types of issues. We will continue migrating away from our legacy web serving infrastructure to improve consistency and reliability. Finally, we are reviewing our internal processes and will be adjusting them to better prevent cross-region outages going forward.

Posted Oct 23, 2023 - 12:01 EDT

Resolved
This incident has been resolved.
Posted Oct 18, 2023 - 10:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2023 - 10:30 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 18, 2023 - 10:23 EDT
Investigating
We are currently investigating this issue.
Posted Oct 18, 2023 - 10:05 EDT
This incident affected: Transact.