Dashboard Inaccessible
Incident Report for Admiral
Postmortem

Overview

Between 13:29 ET and 13:51 ET on March 27, 2024, the Admiral Dashboard was inaccessible and customers saw an error message.

Incident Summary

During the timeframe customers trying to login or otherwise access the Admiral Dashboard were shown an error message. No workaround was identified. All of these issues were simultaneously corrected.

Root Cause Analysis

A misbehaving service led to instability across multiple servers that host the Dashboard. Since the instability affected all relevant servers a user-facing error message was served.

Mitigation Steps

Once the misbehaving service was identified as the cause the quickest resolution was to restart the relevant servers. As servers came back online the Dashboard quickly recovered.

Preventive Measures

Admiral will continue to improve redundancies surrounding our Dashboard and reevaluate our service architecture. We have already deployed a mitigation step and have outlined future steps to further harden our architecture.

Posted Apr 08, 2024 - 11:36 EDT

Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 14:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2024 - 13:54 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 27, 2024 - 13:51 EDT
Investigating
We are currently investigating this issue.
Posted Mar 27, 2024 - 13:46 EDT
This incident affected: Publisher Dashboard.